Monthly Archives: December 2017

macOS High Sierra Patcher Tool for Unsupported Macs

When I attempted to install Xcode on a Mid 2009 MacBook Pro the system told me I had to update macOS to the latest build. Unfortunately Apple’s latest macOS High Sierra wasn’t officially supported on my system, as is the case for many of Apples systems.

This would mean you would have to buy a new (or newer) model system just to install Xcode. It wasn’t even Xcode we wanted to use, it was just that the software we wanted to run required it to be installed. Well, we weren’t having any of this!

I started looking into which systems were supported by High Sierra and one of them was the Late 2009 MBP. Looking at the specifications for the Mid & late 2009 models, I could see they used the same hardware. This lead me into thinking rather then modifying any of the .kext files, I could simply flash the newer EFI firmware onto the system. But while looking into this I came across a posting mentioning another way of doing it using a method created by dosdude1 and I thought I would give his method a shot.

The result was flawless!
The MacBook Pro 5,5 system was now running 10.3.12 beautifully and without any issues. If you own an older Mac system and want to run the latest macOS High Sierra, I highly recommend taking a look at this guide by dosdude1.

If you have a little more courage and feel like flashing the newer EFI Bios please let me know how it works out for you.

 

 

Advertisements